aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-07-09 22:13:19 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-07-12 21:18:41 +0200
commit9af22f1ac9122b54700dd38f627fdd446e1109f4 (patch)
treed98234d375eeb32677d789d93bda93cf95911872 /include
parent6bdd5d8459cca7ceb93c841cccf61dc7ce830092 (diff)
downloadupstream-9af22f1ac9122b54700dd38f627fdd446e1109f4.tar.gz
upstream-9af22f1ac9122b54700dd38f627fdd446e1109f4.tar.bz2
upstream-9af22f1ac9122b54700dd38f627fdd446e1109f4.zip
include/feeds.mk: always add available feeds to PACKAGE_SUBDIRS
Setting CONFIG_FEED_... symbols combined two different effects: Disabling a feed in the generated opkg distfeeds.conf, and omitting the feed from PACKAGE_SUBDIRS. It does not make sense to omit built feeds from PACKAGE_SUBDIRS, as it will only lead to packages that can be enabled in .config (and that will consequently be built) not to be found during rootfs creation, breaking the build. All feeds that packages are emitted to should simply always be added to PACKAGE_SUBDIRS instead; the CONFIG_FEED_... only configure the generated distfeeds.conf like this. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'include')
-rw-r--r--include/feeds.mk6
1 files changed, 1 insertions, 5 deletions
diff --git a/include/feeds.mk b/include/feeds.mk
index cecd30424f..c9ffa95a36 100644
--- a/include/feeds.mk
+++ b/include/feeds.mk
@@ -16,11 +16,7 @@ FEEDS_DISABLED:=$(filter-out $(FEEDS_ENABLED),$(FEEDS_AVAILABLE))
PACKAGE_SUBDIRS=$(PACKAGE_DIR)
ifneq ($(CONFIG_PER_FEED_REPO),)
PACKAGE_SUBDIRS += $(OUTPUT_DIR)/packages/$(ARCH_PACKAGES)/base
- ifneq ($(CONFIG_PER_FEED_REPO_ADD_DISABLED),)
- PACKAGE_SUBDIRS += $(foreach FEED,$(FEEDS_AVAILABLE),$(OUTPUT_DIR)/packages/$(ARCH_PACKAGES)/$(FEED))
- else
- PACKAGE_SUBDIRS += $(foreach FEED,$(FEEDS_ENABLED),$(OUTPUT_DIR)/packages/$(ARCH_PACKAGES)/$(FEED))
- endif
+ PACKAGE_SUBDIRS += $(foreach FEED,$(FEEDS_AVAILABLE),$(OUTPUT_DIR)/packages/$(ARCH_PACKAGES)/$(FEED))
endif
opkg_package_files = $(wildcard \