aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-07-24 15:23:05 +0200
committerJo-Philipp Wich <jo@mein.io>2018-07-24 15:23:05 +0200
commit991c7a4f69976f72bcee3f76d6917b224da45ea1 (patch)
tree0c35c843944cf999d3b0adf30a32b4bc4b95bd2f /include
parenta6f4c7bce8c62d2dded5c8c12f7f118e2a6c9ee5 (diff)
downloadupstream-991c7a4f69976f72bcee3f76d6917b224da45ea1.tar.gz
upstream-991c7a4f69976f72bcee3f76d6917b224da45ea1.tar.bz2
upstream-991c7a4f69976f72bcee3f76d6917b224da45ea1.zip
build: do not override CCACHE_DIR when ccache is disabled
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'include')
-rw-r--r--include/host-build.mk2
-rw-r--r--include/package.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index a2a31ae048..827ea6bbfb 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -132,7 +132,7 @@ define Host/Exports/Default
$(1) : export STAGING_PREFIX=$$(HOST_BUILD_PREFIX)
$(1) : export PKG_CONFIG_PATH=$$(STAGING_DIR_HOST)/lib/pkgconfig:$$(HOST_BUILD_PREFIX)/lib/pkgconfig
$(1) : export PKG_CONFIG_LIBDIR=$$(HOST_BUILD_PREFIX)/lib/pkgconfig
- $(1) : export CCACHE_DIR:=$(STAGING_DIR_HOST)/ccache
+ $(if $(CONFIG_CCACHE),$(1) : export CCACHE_DIR:=$(STAGING_DIR_HOST)/ccache)
$(if $(HOST_CONFIG_SITE),$(1) : export CONFIG_SITE:=$(HOST_CONFIG_SITE))
$(if $(IS_PACKAGE_BUILD),$(1) : export PATH=$$(TARGET_PATH_PKG))
endef
diff --git a/include/package.mk b/include/package.mk
index 2473eecb92..a03db11119 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -144,7 +144,7 @@ define Build/Exports/Default
$(1) : export CONFIG_SITE:=$$(CONFIG_SITE)
$(1) : export PKG_CONFIG_PATH:=$$(PKG_CONFIG_PATH)
$(1) : export PKG_CONFIG_LIBDIR:=$$(PKG_CONFIG_PATH)
- $(1) : export CCACHE_DIR:=$(STAGING_DIR)/ccache
+ $(if $(CONFIG_CCACHE),$(1) : export CCACHE_DIR:=$(STAGING_DIR)/ccache)
endef
Build/Exports=$(Build/Exports/Default)