aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2018-06-09 09:11:24 +0100
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2018-07-03 14:19:10 +0100
commit89b59994eb44b5cd2fac594144c20c63fd05ef25 (patch)
tree33b4ae22354b904916c5ac98dace3ce342118892 /include
parent900d86766b2a2122ea435d98aa50dc72d5dadf93 (diff)
downloadupstream-89b59994eb44b5cd2fac594144c20c63fd05ef25.tar.gz
upstream-89b59994eb44b5cd2fac594144c20c63fd05ef25.tar.bz2
upstream-89b59994eb44b5cd2fac594144c20c63fd05ef25.zip
build: ASLR hardening use $(FPIC)
Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Diffstat (limited to 'include')
-rw-r--r--include/hardening.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/hardening.mk b/include/hardening.mk
index 06a61789ef..42ce1f56b5 100644
--- a/include/hardening.mk
+++ b/include/hardening.mk
@@ -18,7 +18,7 @@ ifdef CONFIG_PKG_CHECK_FORMAT_SECURITY
endif
ifdef CONFIG_PKG_ASLR_PIE
ifeq ($(strip $(PKG_ASLR_PIE)),1)
- TARGET_CFLAGS += -fPIC
+ TARGET_CFLAGS += $(FPIC)
TARGET_LDFLAGS += -specs=$(INCLUDE_DIR)/hardened-ld-pie.specs
endif
endif