aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-07-02 14:19:42 +0200
committerFelix Fietkau <nbd@nbd.name>2018-07-02 14:27:04 +0200
commit516d995d6ada872701e05fab12c0655ea2025eca (patch)
tree73cecbe3c104c1f7b33709a1603b9675a7a275e1 /include
parent433d71e73e60751ea2d6cb1f875375ff9cfbaeb3 (diff)
downloadupstream-516d995d6ada872701e05fab12c0655ea2025eca.tar.gz
upstream-516d995d6ada872701e05fab12c0655ea2025eca.tar.bz2
upstream-516d995d6ada872701e05fab12c0655ea2025eca.zip
build: ensure that iwinfo is selected when building for multiple devices
extra_packages needs to be added there, like on profiles and target packages lists Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include')
-rw-r--r--include/image.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index d358054008..f2a85f6feb 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -393,6 +393,7 @@ endef
define Device/Check/Common
_PROFILE_SET = $$(strip $$(foreach profile,$$(PROFILES) DEVICE_$(1),$$(call DEVICE_CHECK_PROFILE,$$(profile))))
+ DEVICE_PACKAGES += $$(call extra_packages,$$(DEVICE_PACKAGES))
ifdef TARGET_PER_DEVICE_ROOTFS
$$(eval $$(call merge_packages,_PACKAGES,$$(DEVICE_PACKAGES) $$(call DEVICE_EXTRA_PACKAGES,$(1))))
ROOTFS_ID/$(1) := $$(if $$(_PROFILE_SET),$$(call mkfs_packages_id,$$(_PACKAGES)))