aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-07-10 00:00:01 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-07-12 21:18:41 +0200
commit16035a7dd370671670693af9ae63368ee4dd731f (patch)
tree020a3f5bfb365feb0bd566712b85174387e7d509 /include
parent6dac434c0011524b9ac01725727faa1a19ea4a48 (diff)
downloadupstream-16035a7dd370671670693af9ae63368ee4dd731f.tar.gz
upstream-16035a7dd370671670693af9ae63368ee4dd731f.tar.bz2
upstream-16035a7dd370671670693af9ae63368ee4dd731f.zip
include/feeds.mk: rework generation of opkg distfeeds.conf
Allow enabling/commenting/disabling each feed individually by using a tristate config symbol. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'include')
-rw-r--r--include/feeds.mk11
1 files changed, 5 insertions, 6 deletions
diff --git a/include/feeds.mk b/include/feeds.mk
index c9ffa95a36..3e0801e656 100644
--- a/include/feeds.mk
+++ b/include/feeds.mk
@@ -10,8 +10,6 @@
FEEDS_INSTALLED:=$(notdir $(wildcard $(TOPDIR)/package/feeds/*))
FEEDS_AVAILABLE:=$(sort $(FEEDS_INSTALLED) $(shell $(SCRIPT_DIR)/feeds list -n))
-FEEDS_ENABLED:=$(foreach feed,$(FEEDS_AVAILABLE),$(if $(CONFIG_FEED_$(feed)),$(feed)))
-FEEDS_DISABLED:=$(filter-out $(FEEDS_ENABLED),$(FEEDS_AVAILABLE))
PACKAGE_SUBDIRS=$(PACKAGE_DIR)
ifneq ($(CONFIG_PER_FEED_REPO),)
@@ -35,10 +33,11 @@ endef
# 1: destination file
define FeedSourcesAppend
( \
- echo "src/gz %d_core %U/targets/%S/packages"; \
+ echo 'src/gz %d_core %U/targets/%S/packages'; \
+ echo 'src/gz %d_base %U/packages/%A/base'; \
$(strip $(if $(CONFIG_PER_FEED_REPO), \
- $(foreach feed,base $(FEEDS_ENABLED),echo "src/gz %d_$(feed) %U/packages/%A/$(feed)";) \
- $(if $(CONFIG_PER_FEED_REPO_ADD_DISABLED), \
- $(foreach feed,$(FEEDS_DISABLED),echo "$(if $(CONFIG_PER_FEED_REPO_ADD_COMMENTED),# )src/gz %d_$(feed) %U/packages/%A/$(feed)";)))) \
+ $(foreach feed,$(FEEDS_AVAILABLE), \
+ $(if $(CONFIG_FEED_$(feed)), \
+ echo '$(if $(filter m,$(CONFIG_FEED_$(feed))),# )src/gz %d_$(feed) %U/packages/%A/$(feed)';)))) \
) >> $(1)
endef