aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-12 11:09:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-12 11:09:05 +0000
commit0e3a29c270904f3b7be0dabbecd0401488318809 (patch)
tree713e854fcef841cb6c0b3173873d7107ca727da7 /include
parent5605b82835d762cac910dd640ade13f8c4a3668e (diff)
downloadupstream-0e3a29c270904f3b7be0dabbecd0401488318809.tar.gz
upstream-0e3a29c270904f3b7be0dabbecd0401488318809.tar.bz2
upstream-0e3a29c270904f3b7be0dabbecd0401488318809.zip
Fix the annoying base-files autorebuild bug. When checking file mtimes in directories, timestamp.pl was following symlinks. This broke on base-files, because there are symlinks to /tmp and to /proc/mounts in the build directory.
SVN-Revision: 6084
Diffstat (limited to 'include')
-rw-r--r--include/package.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package.mk b/include/package.mk
index 1b69cf25d6..ffab228aae 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -21,7 +21,7 @@ define Build/DefaultTargets
ifeq ($(DUMP),)
ifeq ($(CONFIG_AUTOREBUILD),y)
_INFO:=
- ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) .),$(PKG_BUILD_DIR))
+ ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) . $(PKG_FILE_DEPEND)),$(PKG_BUILD_DIR))
_INFO+=$(subst $(TOPDIR)/,,$(PKG_BUILD_DIR))
$(PKG_BUILD_DIR)/.prepared: package-clean
endif