aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2017-01-03 18:15:15 -0700
committerJo-Philipp Wich <jo@mein.io>2017-12-13 15:00:21 +0100
commitc8a0f3aa290c7f64dbfe5337537defe660952c0c (patch)
treeabc2dd5c492fdab72ce46416802b56d8fe88c48a /include
parent977db9f08aac4f8f769e0a5bf6e6a188621f2ee4 (diff)
downloadupstream-c8a0f3aa290c7f64dbfe5337537defe660952c0c.tar.gz
upstream-c8a0f3aa290c7f64dbfe5337537defe660952c0c.tar.bz2
upstream-c8a0f3aa290c7f64dbfe5337537defe660952c0c.zip
target.mk: check that CPU_TYPE has known CPU_CFLAGS mapping
If someone creates a target and indicates a CPU_TYPE, but there's no corresponding support for that CPU_TYPE's flags in include/target.mk then that should probably be indicated rather than silently ignored. Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com> (cherry picked from commit d3bc11857af788e185e8a3ece26ce40757cf3965)
Diffstat (limited to 'include')
-rw-r--r--include/target.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index 30994485e1..169ce6247a 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -218,6 +218,11 @@ ifeq ($(DUMP),1)
CPU_CFLAGS_arc700 = -marc700
CPU_CFLAGS_archs = -marchs
endif
+ ifneq ($(CPU_TYPE),)
+ ifndef CPU_CFLAGS_$(CPU_TYPE)
+ $(warning CPU_TYPE "$(CPU_TYPE)" doesn't correspond to a known type)
+ endif
+ endif
DEFAULT_CFLAGS=$(strip $(CPU_CFLAGS) $(CPU_CFLAGS_$(CPU_TYPE)) $(CPU_CFLAGS_$(CPU_SUBTYPE)))
ifneq ($(BOARD),)