aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-06-14 17:43:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-06-14 17:43:22 +0000
commitf8d7a53dfe797d5f2ba754c16fe5a9864295ad00 (patch)
treeb8c11538daf15ae6af0123d3bcf1787f524750d9 /include
parent956f2da49e5f3ef4f1fa0fa3f302558c0d60351b (diff)
downloadupstream-f8d7a53dfe797d5f2ba754c16fe5a9864295ad00.tar.gz
upstream-f8d7a53dfe797d5f2ba754c16fe5a9864295ad00.tar.bz2
upstream-f8d7a53dfe797d5f2ba754c16fe5a9864295ad00.zip
include/scan.mk: Add -a argument to the grep to treat all Makefiles as a text file.
Hello, I found out that in some rare cases grep can treat Makefile as a binary file. That happened to me on UTF-8 Gentoo if Makefile contained a character which was from extended ASCII table. Without this patch the output of the grep command in the $(FILELIST) target is not valid (contains line "Binary file matches") and following commands fail to create feed index file. Best Regards, Martin Strbacka Signed-off-by: Martin Strbacka <martin.strbacka@nic.cz> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45966 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/scan.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/scan.mk b/include/scan.mk
index c2a8f7eabb..5af035972f 100644
--- a/include/scan.mk
+++ b/include/scan.mk
@@ -55,7 +55,7 @@ endif
$(FILELIST): $(OVERRIDELIST)
rm -f $(TMP_DIR)/info/.files-$(SCAN_TARGET)-*
- $(call FIND_L, $(SCAN_DIR)) $(SCAN_EXTRA) -mindepth 1 $(if $(SCAN_DEPTH),-maxdepth $(SCAN_DEPTH)) -name Makefile | xargs grep -HE 'call $(GREP_STRING)' | sed -e 's#^$(SCAN_DIR)/##' -e 's#/Makefile:.*##' | uniq | awk -v of=$(OVERRIDELIST) -f include/scan.awk > $@
+ $(call FIND_L, $(SCAN_DIR)) $(SCAN_EXTRA) -mindepth 1 $(if $(SCAN_DEPTH),-maxdepth $(SCAN_DEPTH)) -name Makefile | xargs grep -aHE 'call $(GREP_STRING)' | sed -e 's#^$(SCAN_DIR)/##' -e 's#/Makefile:.*##' | uniq | awk -v of=$(OVERRIDELIST) -f include/scan.awk > $@
$(TMP_DIR)/info/.files-$(SCAN_TARGET).mk: $(FILELIST)
( \