aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-10-05 14:12:42 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-10-05 14:12:42 +0000
commitd618a2b86eb13d3a093be558d3f363ddfee60a82 (patch)
tree41d2c8ed326547551af8322583845ee56b03be26 /include
parent1a174507895ac5c30405eb002317dbc410c77105 (diff)
downloadupstream-d618a2b86eb13d3a093be558d3f363ddfee60a82.tar.gz
upstream-d618a2b86eb13d3a093be558d3f363ddfee60a82.tar.bz2
upstream-d618a2b86eb13d3a093be558d3f363ddfee60a82.zip
build: use host cflags/ldflags for openssl prereq check
Signed-off-by: Felix Fietkau <nbd@openwrt.org> Backport of r47138 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47140 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/prereq-build.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 211201af3d..32c4adabb7 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -68,7 +68,7 @@ $(eval $(call TestHostCommand,zlib, \
$(eval $(call TestHostCommand,libssl, \
Please install the openssl library (with development headers), \
echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
- gcc -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl))
+ gcc $(HOST_CFLAGS) -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl $(HOST_LDFLAGS)))
$(eval $(call SetupHostCommand,tar,Please install GNU 'tar', \