aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-10-05 14:12:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-10-05 14:12:45 +0000
commitcb0229b494fea15d32c868a6d19acb468cef02f3 (patch)
tree5cca180cbedacbacde9b7dd29a5d985cd825aafe /include
parentd618a2b86eb13d3a093be558d3f363ddfee60a82 (diff)
downloadupstream-cb0229b494fea15d32c868a6d19acb468cef02f3.tar.gz
upstream-cb0229b494fea15d32c868a6d19acb468cef02f3.tar.bz2
upstream-cb0229b494fea15d32c868a6d19acb468cef02f3.zip
build: include homebrew include/library directory in cflags/ldflags on mac os x
Signed-off-by: Felix Fietkau <nbd@openwrt.org> Backport of r47139 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47141 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/host-build.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 760d38b371..e2b5f2f8d1 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -50,6 +50,11 @@ define Host/Prepare
$(call Host/Prepare/Default)
endef
+ifeq ($(HOST_OS),Darwin)
+ HOST_CFLAGS += -I/usr/local/opt/openssl/include
+ HOST_LDFLAGS += -L/usr/local/opt/openssl/lib
+endif
+
HOST_CONFIGURE_VARS = \
CC="$(HOSTCC)" \
CFLAGS="$(HOST_CFLAGS)" \