aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-10-15 21:37:31 +0000
committerLuka Perkov <luka@openwrt.org>2013-10-15 21:37:31 +0000
commit9eb69ef0dc7d3fe0c92d5225ad3d7b5e9672dfec (patch)
tree64596a9ce786c350e1ad3525940ca59afa4e90df /include
parent85eaf1d6bece89d4c243366e268ef57bcb388359 (diff)
downloadupstream-9eb69ef0dc7d3fe0c92d5225ad3d7b5e9672dfec.tar.gz
upstream-9eb69ef0dc7d3fe0c92d5225ad3d7b5e9672dfec.tar.bz2
upstream-9eb69ef0dc7d3fe0c92d5225ad3d7b5e9672dfec.zip
ubifs: remove breaking commas from ubi calls
The extra commas get output by the shell resulting in errors since the commands that get called with those extra commas are then malformed. Signed-off-by: Joris de Vries <joris@apptrician.nl> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38419 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/image.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index c79d823538..8f895a3435 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -125,7 +125,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
$(STAGING_DIR_HOST)/bin/mkfs.ubifs \
$(if $($(PROFILE)_UBIFS_OPTS), \
$(shell echo $($(PROFILE)_UBIFS_OPTS)), \
- $(shell echo $(UBIFS_OPTS)), \
+ $(shell echo $(UBIFS_OPTS)) \
) \
$(if $(CONFIG_TARGET_UBIFS_FREE_SPACE_FIXUP),--space-fixup) \
$(if $(CONFIG_TARGET_UBIFS_COMPRESSION_NONE),--force-compr=none) \
@@ -143,7 +143,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
$(STAGING_DIR_HOST)/bin/ubinize \
$(if $($(PROFILE)_UBI_OPTS), \
$(shell echo $($(PROFILE)_UBI_OPTS)), \
- $(shell echo $(UBI_OPTS)), \
+ $(shell echo $(UBI_OPTS)) \
) \
-o $(KDIR)/root.ubi \
ubinize.cfg \