aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-05-29 13:41:21 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-05-29 13:41:21 +0000
commit9272d8d2f77a9be2399a358711f92c27c5230a10 (patch)
tree30c0ba1a095a18898472ce76b78263d91aea79af /include
parent0f9bf923fe83f9a0514988cd8184fb852ab4f45b (diff)
downloadupstream-9272d8d2f77a9be2399a358711f92c27c5230a10.tar.gz
upstream-9272d8d2f77a9be2399a358711f92c27c5230a10.tar.bz2
upstream-9272d8d2f77a9be2399a358711f92c27c5230a10.zip
build: in new image building code, do not rebuild kernel images in the image builder
Some kernel images need to be wrapped in a loader, which cannot be built without a working toolchain. Also, this speeds up the image builder run. Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45836 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/image.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 8e8ddc29ac..051f0f7e53 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -397,10 +397,15 @@ define Device/Build/kernel
$$(_TARGET): $$(if $$(KERNEL_INSTALL),$(BIN_DIR)/$$(KERNEL_IMAGE))
$(BIN_DIR)/$$(KERNEL_IMAGE): $(KDIR)/$$(KERNEL_IMAGE)
cp $$^ $$@
- $(KDIR)/$$(KERNEL_IMAGE): $(KDIR)/$$(KERNEL_NAME)
+ ifndef IB
+ ifdef CONFIG_IB
+ install: $(KDIR)/$$(KERNEL_IMAGE)
+ endif
+ $(KDIR)/$$(KERNEL_IMAGE): $(KDIR)/$$(KERNEL_NAME)
@rm -f $$@
$$(call concat_cmd,$$(KERNEL))
$$(if $$(KERNEL_SIZE),$$(call Device/Build/check_size,$$(KERNEL_SIZE)))
+ endif
endef
define Device/Build/image