aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-07-17 11:37:47 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-07-17 11:37:47 +0000
commit751a531bff6186a7f2f218e63372b646d5c75781 (patch)
tree26e31de5318bcb26f3b8f79dc15dd1c5ebd1df4f /include
parent150f3a3b225a17bf6de0db7f3929303621762edf (diff)
downloadupstream-751a531bff6186a7f2f218e63372b646d5c75781.tar.gz
upstream-751a531bff6186a7f2f218e63372b646d5c75781.tar.bz2
upstream-751a531bff6186a7f2f218e63372b646d5c75781.zip
CC: toplevel.mk: fix LD_LIBRARY_PATH for host binaries
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> Backport of r46394 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@46395 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/toplevel.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index bbeb7ebcef..11b2dd9e29 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -24,8 +24,8 @@ OPENWRTVERSION:=$(RELEASE)$(if $(REVISION), ($(REVISION)))
export RELEASE
export REVISION
export OPENWRTVERSION
-export LD_LIBRARY_PATH:=$(subst ::,:,$(if $(LD_LIBRARY_PATH),$(LD_LIBRARY_PATH):)$(STAGING_DIR_HOST)/lib)
-export DYLD_LIBRARY_PATH:=$(subst ::,:,$(if $(DYLD_LIBRARY_PATH),$(DYLD_LIBRARY_PATH):)$(STAGING_DIR_HOST)/lib)
+export LD_LIBRARY_PATH:=$(subst ::,:,$(if $(LD_LIBRARY_PATH),$(LD_LIBRARY_PATH):)$(TOPDIR)/staging_dir/host/lib)
+export DYLD_LIBRARY_PATH:=$(subst ::,:,$(if $(DYLD_LIBRARY_PATH),$(DYLD_LIBRARY_PATH):)$(TOPDIR)/staging_dir/host/lib)
export GIT_CONFIG_PARAMETERS='core.autocrlf=false'
export MAKE_JOBSERVER=$(filter --jobserver%,$(MAKEFLAGS))