aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-05-10 11:46:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-05-10 11:46:50 +0000
commit59606690fb6fc974b6f7ace02049d4892df20f18 (patch)
treea86dc13485ab6a337490b504c59e86e9d2cd6f8d /include
parent4022f5a9f4c15ccf8e95ea5ae0f562a5dc3df718 (diff)
downloadupstream-59606690fb6fc974b6f7ace02049d4892df20f18.tar.gz
upstream-59606690fb6fc974b6f7ace02049d4892df20f18.tar.bz2
upstream-59606690fb6fc974b6f7ace02049d4892df20f18.zip
include: make dtb argument optional in MkFIT
As mkits.sh makes the -d argument optional, we'll make this same argument optional in the MkFIT function as well. With this change, MkFIT can be used both to generate FIT images with DT, and without DT. Signed-off-by: Mathieu Olivari <mathieu@qca.qualcomm.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45660 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 788d593f94..a6237ff2e2 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -121,7 +121,7 @@ endef
define Image/BuildKernel/MkFIT
$(TOPDIR)/scripts/mkits.sh \
- -D $(1) -o $(KDIR)/fit-$(1).its -k $(2) -d $(3) -C $(4) -a $(5) -e $(6) \
+ -D $(1) -o $(KDIR)/fit-$(1).its -k $(2) $(if $(3),-d $(3)) -C $(4) -a $(5) -e $(6) \
-A $(ARCH) -v $(LINUX_VERSION)
PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $(KDIR)/fit-$(1).its $(KDIR)/fit-$(1)$(7).itb
endef