aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-02-29 20:02:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-02-29 20:02:34 +0000
commit42eb04666165c474c083e0b19dce7732fb167e3a (patch)
tree860a02ee47e515680eb5595be557b33ac00d4abd /include
parentf3a1db04f0ebba577598f1577d3c8c756c8bf757 (diff)
downloadupstream-42eb04666165c474c083e0b19dce7732fb167e3a.tar.gz
upstream-42eb04666165c474c083e0b19dce7732fb167e3a.tar.bz2
upstream-42eb04666165c474c083e0b19dce7732fb167e3a.zip
build: add support for choosing a different url filename part than the output file
Signed-off-by: Felix Fietkau <nbd@openwrt.org> Backport of r47591 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@48823 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/download.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/include/download.mk b/include/download.mk
index 937b5d3b63..8a1205df00 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -44,11 +44,11 @@ define DownloadMethod/unknown
endef
define DownloadMethod/default
- $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "$(MD5SUM)" $(foreach url,$(URL),"$(url)")
+ $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "$(MD5SUM)" "$(URL_FILE)" $(foreach url,$(URL),"$(url)")
endef
define wrap_mirror
- $(if $(if $(MIRROR),$(filter-out x,$(MIRROR_MD5SUM))),@$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "$(MIRROR_MD5SUM)" || ( $(1) ),$(1))
+ $(if $(if $(MIRROR),$(filter-out x,$(MIRROR_MD5SUM))),@$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "" "$(MIRROR_MD5SUM)" || ( $(1) ),$(1))
endef
define DownloadMethod/cvs
@@ -157,6 +157,7 @@ Validate/darcs=VERSION SUBDIR
define Download/Defaults
URL:=
FILE:=
+ URL_FILE:=
PROTO:=
MD5SUM:=
SUBDIR:=