aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-04-16 12:18:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-04-16 12:18:26 +0000
commit3ed309fd915358e94284728a01dc4fd6195d4b1a (patch)
tree4a4cafed5b61820f4078deae53eb297b135f8a4d /include
parent3ec7a94d57d5b1b75f409a480b7a99f03fddb2a1 (diff)
downloadupstream-3ed309fd915358e94284728a01dc4fd6195d4b1a.tar.gz
upstream-3ed309fd915358e94284728a01dc4fd6195d4b1a.tar.bz2
upstream-3ed309fd915358e94284728a01dc4fd6195d4b1a.zip
build: tell users to do non-paralle builds on errors
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45457 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/toplevel.mk7
-rw-r--r--include/verbose.mk2
2 files changed, 7 insertions, 2 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 33baa86da9..d8651d923b 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -166,6 +166,8 @@ clean dirclean: .config
prereq:: prepare-tmpinfo .config
@+$(NO_TRACE_MAKE) -r -s $@
+WARN_PARALLEL_ERROR = $(if $(BUILD_LOG),,$(and $(filter -j,$(MAKEFLAGS)),$(findstring s,$(OPENWRT_VERBOSE))))
+
ifeq ($(SDK),1)
%::
@@ -184,7 +186,10 @@ else
printf "$(_R)WARNING: your configuration is out of sync. Please run make menuconfig, oldconfig or defconfig!$(_N)\n" >&2; \
fi \
)
- @+$(ULIMIT_FIX) $(SUBMAKE) -r $@
+ @+$(ULIMIT_FIX) $(SUBMAKE) -r $@ $(if $(WARN_PARALLEL_ERROR), || { \
+ printf "$(_R)Build failed - please re-run with -j1 to see the real error message$(_N)\n" >&2; \
+ false; \
+ } )
endif
diff --git a/include/verbose.mk b/include/verbose.mk
index 90aab4c2f5..b7e43f7430 100644
--- a/include/verbose.mk
+++ b/include/verbose.mk
@@ -54,7 +54,7 @@ ifeq ($(findstring s,$(OPENWRT_VERBOSE)),)
else
SILENT:=>/dev/null $(if $(findstring w,$(OPENWRT_VERBOSE)),,2>&1)
export QUIET:=1
- SUBMAKE=cmd() { $(SILENT) $(MAKE) -s $$* < /dev/null || { echo "make $$*: build failed. Please re-run make with V=s to see what's going on"; false; } } 8>&1 9>&2; cmd
+ SUBMAKE=cmd() { $(SILENT) $(MAKE) -s $$* < /dev/null || { echo "make $$*: build failed. Please re-run make with -j1 V=s to see what's going on"; false; } } 8>&1 9>&2; cmd
endif
.SILENT: $(MAKECMDGOALS)