aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-18 21:12:18 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-18 21:12:18 +0000
commit25fe6a2e0463d47da598c8e22cd242e9c9fcbad1 (patch)
tree6d92e02e200b8fd692c14a85c5f7f8959ae8fb8f /include
parente438f2500b19dbb9020f8d26105e838e86cb7ebb (diff)
downloadupstream-25fe6a2e0463d47da598c8e22cd242e9c9fcbad1.tar.gz
upstream-25fe6a2e0463d47da598c8e22cd242e9c9fcbad1.tar.bz2
upstream-25fe6a2e0463d47da598c8e22cd242e9c9fcbad1.zip
add prereq checks for target/linux/* and target/image/*, check for fdisk for the x86 builds
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5569 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/image.mk1
-rw-r--r--include/kernel-build.mk2
2 files changed, 3 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 6805389d72..70677b9c2f 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -5,6 +5,7 @@
# See /LICENSE for more information.
#
+include $(INCLUDE_DIR)/prereq.mk
include $(INCLUDE_DIR)/kernel.mk
KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 35149d7686..4967dfb67e 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -6,6 +6,8 @@
#
KERNEL_BUILD:=1
+include $(INCLUDE_DIR)/prereq.mk
+
# For target profile selection - the default set
DEFAULT_PACKAGES:=base-files libgcc uclibc bridge busybox dnsmasq dropbear iptables mtd ppp ppp-mod-pppoe mtd