aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-04-20 13:57:43 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-04-20 13:57:43 +0000
commit17edbdb9a6dccc28f0d2c4a34672ccf3d677bf85 (patch)
tree318da50bb9d43ddc4959bc1a774ea75c45585477 /include
parentd08f0c7353391ea04f07bc9a63a7446db0e38d85 (diff)
downloadupstream-17edbdb9a6dccc28f0d2c4a34672ccf3d677bf85.tar.gz
upstream-17edbdb9a6dccc28f0d2c4a34672ccf3d677bf85.tar.bz2
upstream-17edbdb9a6dccc28f0d2c4a34672ccf3d677bf85.zip
all: replace genext2fs with make_ext4fs
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45517 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/image.mk14
1 files changed, 7 insertions, 7 deletions
diff --git a/include/image.mk b/include/image.mk
index bd6a88af61..788d593f94 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -231,15 +231,15 @@ define Image/mkfs/targz
$(TAR) -czpf $(BIN_DIR)/$(IMG_PREFIX)$(if $(PROFILE),-$(PROFILE))-rootfs.tar.gz --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
endef
-E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_PARTSIZE)*1024*1024/$(CONFIG_TARGET_EXT4_BLOCKSIZE))))
+E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_PARTSIZE)*1024*1024)))
define Image/mkfs/ext4
-# generate an ext2 fs
- $(STAGING_DIR_HOST)/bin/genext2fs -U -B $(CONFIG_TARGET_EXT4_BLOCKSIZE) -b $(E2SIZE) -N $(CONFIG_TARGET_EXT4_MAXINODE) -d $(TARGET_DIR)/ $(KDIR)/root.ext4 -m $(CONFIG_TARGET_EXT4_RESERVED_PCT) $(MKFS_DEVTABLE_OPT)
-# convert it to ext4
- $(STAGING_DIR_HOST)/bin/tune2fs $(if $(CONFIG_TARGET_EXT4_JOURNAL),-j) -O extents,uninit_bg,dir_index $(KDIR)/root.ext4
-# fix it up
- $(STAGING_DIR_HOST)/bin/e2fsck -fy $(KDIR)/root.ext4
+ $(STAGING_DIR_HOST)/bin/make_ext4fs \
+ -l $(E2SIZE) -b $(CONFIG_TARGET_EXT4_BLOCKSIZE) \
+ -i $(CONFIG_TARGET_EXT4_MAXINODE) \
+ -m $(CONFIG_TARGET_EXT4_RESERVED_PCT) \
+ $(if $(CONFIG_TARGET_EXT4_JOURNAL),,-J) \
+ $(KDIR)/root.ext4 $(TARGET_DIR)/
endef
define Image/mkfs/prepare/default