aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2007-06-08 10:44:01 +0000
committerImre Kaloz <kaloz@openwrt.org>2007-06-08 10:44:01 +0000
commit15a51103e899264b1689fa9967c4f74c4417bca1 (patch)
treeab9aee6ffb779dd0147f55c0876d42e29802fe90 /include
parentd442289f60548d0c33385edd723ba2eb61cd88c5 (diff)
downloadupstream-15a51103e899264b1689fa9967c4f74c4417bca1.tar.gz
upstream-15a51103e899264b1689fa9967c4f74c4417bca1.tar.bz2
upstream-15a51103e899264b1689fa9967c4f74c4417bca1.zip
add support for the AVR32 platform, namely the ATNGW100 board - joint work with wigyori
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7533 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/kernel-defaults.mk3
-rw-r--r--include/site/avr32-linux-uclibc31
2 files changed, 34 insertions, 0 deletions
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index 529b330851..84030a6d2d 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -21,6 +21,9 @@ endif
ifneq (,$(findstring ppc,$(BOARD)))
KERNELNAME="uImage"
endif
+ifneq (,$(findstring avr32,$(BOARD)))
+ KERNELNAME="uImage"
+endif
KERNEL_MAKEOPTS := -C $(LINUX_DIR) \
CROSS_COMPILE="$(KERNEL_CROSS)" \
diff --git a/include/site/avr32-linux-uclibc b/include/site/avr32-linux-uclibc
new file mode 100644
index 0000000000..5ea25159a6
--- /dev/null
+++ b/include/site/avr32-linux-uclibc
@@ -0,0 +1,31 @@
+#!/bin/sh
+
+ac_cv_c_littleendian=${ac_cv_c_littleendian=no}
+ac_cv_c_bigendian=${ac_cv_c_bigendian=yes}
+
+ac_cv_sizeof___int64=0
+ac_cv_sizeof_char=1
+ac_cv_sizeof_int=4
+ac_cv_sizeof_int16_t=2
+ac_cv_sizeof_int32_t=4
+ac_cv_sizeof_int64_t=8
+ac_cv_sizeof_long_int=4
+ac_cv_sizeof_long_long=8
+ac_cv_sizeof_long=4
+ac_cv_sizeof_off_t=8
+ac_cv_sizeof_short_int=2
+ac_cv_sizeof_short=2
+ac_cv_sizeof_size_t=4
+ac_cv_sizeof_u_int16_t=2
+ac_cv_sizeof_u_int32_t=4
+ac_cv_sizeof_u_int64_t=8
+ac_cv_sizeof_uint16_t=2
+ac_cv_sizeof_uint32_t=4
+ac_cv_sizeof_uint64_t=8
+ac_cv_sizeof_unsigned_int=4
+ac_cv_sizeof_unsigned_long=4
+ac_cv_sizeof_unsigned_short=2
+ac_cv_sizeof_void_p=4
+
+. $TOPDIR/include/site/linux-uclibc
+