aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-02 12:43:13 +0000
committerJohn Crispin <blogic@openwrt.org>2014-06-02 12:43:13 +0000
commitf7c3ef012e46287eea6fa653d1f4af904e4d4dae (patch)
tree412b3c3c1136a920350fdb514539393b3967c52d /include
parent837c7dfb3611bbb823f5fc085882fe4eb85ebcdd (diff)
downloadupstream-f7c3ef012e46287eea6fa653d1f4af904e4d4dae.tar.gz
upstream-f7c3ef012e46287eea6fa653d1f4af904e4d4dae.tar.bz2
upstream-f7c3ef012e46287eea6fa653d1f4af904e4d4dae.zip
include: fix kernel download failure with git & local trees
When using the options EXTERNAL_KERNEL_TREE or KERNEL_GIT_CLONE_URI, the command "make downloads" fails as it tries to download the kernel tarball despite the option. This doesn't happen during a regular build as in that case, the dependency is conditionned through the LINUX_SITE variable, which is not set in these cases. Below is a snapshot of the error for an target using a 3.14 kernel: make[3]: *** No rule to make target `.../dl/linux-3.14.tar.xz', needed by `download'. Stop. Change-Id: I1244969c1bbf9c81a6a64d68ae88ac58b0f8e79e Signed-off-by: Mathieu Olivari <mathieu@qca.qualcomm.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40913 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/kernel-build.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index d34365837d..2bf639218a 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -117,7 +117,7 @@ define BuildKernel
define BuildKernel
endef
- download: $(DL_DIR)/$(LINUX_SOURCE)
+ download: $(if $(LINUX_SITE),$(DL_DIR)/$(LINUX_SOURCE))
prepare: $(STAMP_CONFIGURED)
compile: $(LINUX_DIR)/.modules
$(MAKE) -C image compile TARGET_BUILD=