aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-11 12:59:41 +0000
committerJohn Crispin <blogic@openwrt.org>2014-06-11 12:59:41 +0000
commitf1c0ad03b70dc3b294d67d9af0b150660ca8f269 (patch)
tree9e978b3be426a7fea0954477ca47f7e92560a8cf /include
parent494257f5ab01f15bcf15c6e8f552d0fc26b740d7 (diff)
downloadupstream-f1c0ad03b70dc3b294d67d9af0b150660ca8f269.tar.gz
upstream-f1c0ad03b70dc3b294d67d9af0b150660ca8f269.tar.bz2
upstream-f1c0ad03b70dc3b294d67d9af0b150660ca8f269.zip
include/image.mk: add a target for generating sysupgrade tar files for nand
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41127 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/image.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 53180e43df..ddf19dd4b9 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -129,6 +129,20 @@ ifneq ($(CONFIG_TARGET_ROOTFS_SQUASHFS),)
endef
endif
+# $(1): Board name (small caps)
+# $(2): kernel image
+# $(3): rootfs image
+ifneq ($(CONFIG_NAND_SUPPORT),)
+ define Image/Build/SysupgradeNAND
+ mkdir -p $(KDIR_TMP)/sysupgrade-$(1)/
+ echo "BOARD=$(1)" > $(KDIR_TMP)/sysupgrade-$(1)/CONTROL
+ $(CP) $(2) $(KDIR_TMP)/sysupgrade-$(1)/kernel
+ $(CP) $(3) $(KDIR_TMP)/sysupgrade-$(1)/root
+ (cd $(KDIR_TMP); $(TAR) cvzf \
+ $(call imgname,ubi,$(1))-sysupgrade.tgz sysupgrade-$(1))
+ endef
+endif
+
ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
define Image/mkfs/ubifs/generate
$(CP) ./ubinize$(1).cfg $(KDIR)