aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-08-09 13:05:03 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-08-09 13:05:03 +0000
commitde5a9e61d3179aae32563b6d53bafcb51bd7b010 (patch)
treeaad78c68117956e013bb22eebedb24792ff8e3f2 /include
parent98a9c8bd5be3924ea6ae9edd3018b5b3f49340b1 (diff)
downloadupstream-de5a9e61d3179aae32563b6d53bafcb51bd7b010.tar.gz
upstream-de5a9e61d3179aae32563b6d53bafcb51bd7b010.tar.bz2
upstream-de5a9e61d3179aae32563b6d53bafcb51bd7b010.zip
BB: build: fix removal of old .ipk files with CONFIG_PER_FEED_REPO
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> Backport of r42090 git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@42091 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/package-ipkg.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index be47526467..5c83b3d58b 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -136,7 +136,7 @@ ifeq ($(DUMP),)
$(PKG_INFO_DIR)/$(1).provides: $$(IPKG_$(1))
$$(IPKG_$(1)): $(STAMP_BUILT) $(INCLUDE_DIR)/package-ipkg.mk
- @rm -rf $(PACKAGE_DIR)/$(1)_* $$(IDIR_$(1))
+ @rm -rf $$(PDIR_$(1))/$(1)_* $$(IDIR_$(1))
mkdir -p $(PACKAGE_DIR) $$(IDIR_$(1))/CONTROL $(PKG_INFO_DIR)
$(call Package/$(1)/install,$$(IDIR_$(1)))
-find $$(IDIR_$(1)) -name 'CVS' -o -name '.svn' -o -name '.#*' -o -name '*~'| $(XARGS) rm -rf