aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-13 11:59:16 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-13 11:59:16 +0000
commitcd30f34da529d0d80782c0e5dccd50bba656f8aa (patch)
tree6fdf8ad410aa8feb8934239d6c1dba84f2f3bef2 /include
parent4a54acf279d44111a46129ca3f08a68e41a18b04 (diff)
downloadupstream-cd30f34da529d0d80782c0e5dccd50bba656f8aa.tar.gz
upstream-cd30f34da529d0d80782c0e5dccd50bba656f8aa.tar.bz2
upstream-cd30f34da529d0d80782c0e5dccd50bba656f8aa.zip
BB: build: improve feed handling for opkg.conf
- Consider not installed feeds as well - Add option to decide whether to comment disabled feeds Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> Backport of r42931 git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@44441 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/feeds.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/feeds.mk b/include/feeds.mk
index 97b14491f0..695b03b145 100644
--- a/include/feeds.mk
+++ b/include/feeds.mk
@@ -10,10 +10,12 @@
FEEDS_AVAILABLE:=$(shell $(SCRIPT_DIR)/feeds list -n)
FEEDS_INSTALLED:=$(notdir $(wildcard $(TOPDIR)/package/feeds/*))
FEEDS_ENABLED:=$(foreach feed,$(FEEDS_INSTALLED),$(if $(CONFIG_FEED_$(feed)),$(feed)))
-FEEDS_DISABLED:=$(filter-out $(FEEDS_ENABLED),$(FEEDS_INSTALLED))
+FEEDS_DISABLED:=$(filter-out $(FEEDS_ENABLED),$(FEEDS_AVAILABLE))
PKG_CONFIG_DEPENDS += \
CONFIG_PER_FEED_REPO \
+ CONFIG_PER_FEED_REPO_ADD_DISABLED \
+ CONFIG_PER_FEED_REPO_ADD_COMMENTED \
$(foreach feed,$(FEEDS_INSTALLED),CONFIG_FEED_$(feed))
# 1: package name