aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-06-27 10:32:09 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-06-27 10:32:09 +0000
commitb4696a8be59e3003d7421e6b4e27efce89b7f4eb (patch)
tree0b92917f6ac71f15acf61ef0bff2308d5f0ccf93 /include
parent2c46cfb66b26f798aeef777adaa81b8708b4214d (diff)
downloadupstream-b4696a8be59e3003d7421e6b4e27efce89b7f4eb.tar.gz
upstream-b4696a8be59e3003d7421e6b4e27efce89b7f4eb.tar.bz2
upstream-b4696a8be59e3003d7421e6b4e27efce89b7f4eb.zip
include UbinizeImage parameters' description in the file
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41356 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/image.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 3832b7ae84..71971e21ca 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -141,6 +141,11 @@ ifneq ($(CONFIG_NAND_SUPPORT),)
(cd "$(KDIR_TMP)"; $(TAR) cvf \
"$(BIN_DIR)/$(IMG_PREFIX)-$(1)-$(2)-sysupgrade.tar" sysupgrade-$(1))
endef
+# $(1) board name
+# $(2) ubinize-image options (e.g. --no-kernel and/or --uboot-env)
+# $(3) rootfstype (e.g. squashfs or ubifs)
+# $(4) kernel image file
+# $(5) options to pass-through to ubinize (i.e. $($(PROFILE)_UBI_OPTS)))
define Image/Build/UbinizeImage
sh $(TOPDIR)/scripts/ubinize-image.sh $(2) \
"$(KDIR)/root.$(3)" "$(4)" \