aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-09-07 16:48:03 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-09-07 16:48:03 +0000
commita20ad6d68d1fa231cbf7606c1ada064217723a11 (patch)
treebbc2099579fb1720775ab816f47aab84d2963205 /include
parent8eca9d20eafd3d9f0ae7f76184e7aafb43b555d3 (diff)
downloadupstream-a20ad6d68d1fa231cbf7606c1ada064217723a11.tar.gz
upstream-a20ad6d68d1fa231cbf7606c1ada064217723a11.tar.bz2
upstream-a20ad6d68d1fa231cbf7606c1ada064217723a11.zip
don't run rebuild checks for dump and prereq
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4771 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/package.mk16
1 files changed, 9 insertions, 7 deletions
diff --git a/include/package.mk b/include/package.mk
index 42ffcfbb3c..bea0428129 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -237,14 +237,16 @@ define BuildPackage
$$(eval $$(call Build/DefaultTargets,$(1)))
ifneq ($$(CONFIG_PACKAGE_$(1)),)
- ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install $$(IPKG_$(1)) $(PKG_BUILD_DIR)),$$(IPKG_$(1)))
- _INFO+=$(subst $(TOPDIR)/,,$$(IPKG_$(1)))
- $(PKG_BUILD_DIR)/.built: package-rebuild
- endif
-
ifneq ($(MAKECMDGOALS),prereq)
- ifneq ($$(_INFO),)
- $$(info Rebuilding $$(_INFO))
+ ifneq ($(DUMP),1)
+ ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install $$(IPKG_$(1)) $(PKG_BUILD_DIR)),$$(IPKG_$(1)))
+ _INFO+=$(subst $(TOPDIR)/,,$$(IPKG_$(1)))
+ $(PKG_BUILD_DIR)/.built: package-rebuild
+ endif
+
+ ifneq ($$(_INFO),)
+ $$(info Rebuilding $$(_INFO))
+ endif
endif
endif
endif