aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-08-03 11:15:37 +0000
committerJohn Crispin <blogic@openwrt.org>2014-08-03 11:15:37 +0000
commita0034e03958d4df4ef22804dc87244f332e6289f (patch)
treee8859450de9cb02ac00151cb2a3473535e36c638 /include
parent73e2be1336c9b94b07e9d5e2b32f0cd6a419a896 (diff)
downloadupstream-a0034e03958d4df4ef22804dc87244f332e6289f.tar.gz
upstream-a0034e03958d4df4ef22804dc87244f332e6289f.tar.bz2
upstream-a0034e03958d4df4ef22804dc87244f332e6289f.zip
base-files: add extra version configuration options for OEM manufacturer info
Creates /etc/device_info which will be used to fill in information for WPS and other protocols that need manufacturer/device information This helps with creating OpenWrt firmware for OEM or rebranded devices. Signed-off-by: Felix Fietkau <nbd@openwrt.org> Backport of r41884 git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@41967 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/version.mk16
1 files changed, 15 insertions, 1 deletions
diff --git a/include/version.mk b/include/version.mk
index 66219ecc10..338d590e9a 100644
--- a/include/version.mk
+++ b/include/version.mk
@@ -12,7 +12,10 @@ PKG_CONFIG_DEPENDS += \
CONFIG_VERSION_NUMBER \
CONFIG_VERSION_NICK \
CONFIG_VERSION_REPO \
- CONFIG_VERSION_DIST
+ CONFIG_VERSION_DIST \
+ CONFIG_VERSION_MANUFACTURER \
+ CONFIG_VERSION_PRODUCT \
+ CONFIG_VERSION_HWREV \
VERSION_NUMBER:=$(call qstrip,$(CONFIG_VERSION_NUMBER))
VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),$(REVISION))
@@ -29,6 +32,14 @@ VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/
VERSION_DIST:=$(call qstrip,$(CONFIG_VERSION_DIST))
VERSION_DIST:=$(if $(VERSION_DIST),$(VERSION_DIST),OpenWrt)
+VERSION_MANUFACTURER:=$(call qstrip,$(CONFIG_VERSION_MANUFACTURER))
+VERSION_MANUFACTURER:=$(if $(VERSION_MANUFACTURER),$(VERSION_MANUFACTURER),OpenWrt)
+
+VERSION_PRODUCT:=$(call qstrip,$(CONFIG_VERSION_PRODUCT))
+VERSION_PRODUCT:=$(if $(VERSION_PRODUCT),$(VERSION_PRODUCT),Generic)
+
+VERSION_HWREV:=$(call qstrip,$(CONFIG_VERSION_HWREV))
+VERSION_HWREV:=$(if $(VERSION_HWREV),$(VERSION_HWREV),v0)
define taint2sym
$(CONFIG_$(firstword $(subst :, ,$(subst +,,$(subst -,,$(1))))))
@@ -66,3 +77,6 @@ VERSION_SED:=$(SED) 's,%U,$(VERSION_REPO),g' \
-e 's,%T,$(BOARD),g' \
-e 's,%S,$(BOARD)/$(if $(SUBTARGET),$(SUBTARGET),generic),g' \
-e 's,%t,$(VERSION_TAINTS),g' \
+ -e 's,%M,$(VERSION_MANUFACTURER),g' \
+ -e 's,%P,$(VERSION_PRODUCT),g' \
+ -e 's,%h,$(VERSION_HWREV),g'