aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-16 18:55:18 +0000
committerJohn Crispin <blogic@openwrt.org>2014-06-16 18:55:18 +0000
commit81674531487a3127fe4faf44c01fc37b8e24361a (patch)
tree057be7b53263931abc86a00335838851bda81e20 /include
parenta0be38dafa35ea15b278fe0f7b80f4603853142a (diff)
downloadupstream-81674531487a3127fe4faf44c01fc37b8e24361a.tar.gz
upstream-81674531487a3127fe4faf44c01fc37b8e24361a.tar.bz2
upstream-81674531487a3127fe4faf44c01fc37b8e24361a.zip
include/image.mk: cleanup the SysupgradeNAND template
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41223 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/image.mk12
1 files changed, 7 insertions, 5 deletions
diff --git a/include/image.mk b/include/image.mk
index ddf19dd4b9..605474ce99 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -129,17 +129,19 @@ ifneq ($(CONFIG_TARGET_ROOTFS_SQUASHFS),)
endef
endif
-# $(1): Board name (small caps)
+# $(1): board name
# $(2): kernel image
# $(3): rootfs image
+# $(4): ubi image
ifneq ($(CONFIG_NAND_SUPPORT),)
define Image/Build/SysupgradeNAND
mkdir -p $(KDIR_TMP)/sysupgrade-$(1)/
echo "BOARD=$(1)" > $(KDIR_TMP)/sysupgrade-$(1)/CONTROL
- $(CP) $(2) $(KDIR_TMP)/sysupgrade-$(1)/kernel
- $(CP) $(3) $(KDIR_TMP)/sysupgrade-$(1)/root
- (cd $(KDIR_TMP); $(TAR) cvzf \
- $(call imgname,ubi,$(1))-sysupgrade.tgz sysupgrade-$(1))
+ [ -z "$(2)" ] || $(CP) $(2) $(KDIR_TMP)/sysupgrade-$(1)/kernel
+ [ -z "$(3)" ] || $(CP) $(3) $(KDIR_TMP)/sysupgrade-$(1)/root
+ [ -z "$(4)" ] || $(CP) $(4) $(KDIR_TMP)/sysupgrade-$(1)/ubi
+ (cd $(KDIR_TMP); $(TAR) cvf \
+ $(BIN_DIR)/$(IMG_PREFIX)-$(1)-ubi-sysupgrade.tar sysupgrade-$(1))
endef
endif