aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-08-25 14:50:17 +0000
committerNicolas Thill <nico@openwrt.org>2007-08-25 14:50:17 +0000
commit6980fc88b71f122809412a109f7444b463209488 (patch)
tree3923a179234ecbde27bcd8a8b6703b3dbc9f29e5 /include
parent31779bc3ff0e69decf686ca7ac69eba7bad509c0 (diff)
downloadupstream-6980fc88b71f122809412a109f7444b463209488.tar.gz
upstream-6980fc88b71f122809412a109f7444b463209488.tar.bz2
upstream-6980fc88b71f122809412a109f7444b463209488.zip
move KERNEL_PATCHVER from kernel.mk to kernel-version.mk so that it is defined when dumping target infos
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8485 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/kernel-version.mk1
-rw-r--r--include/kernel.mk1
2 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index f68fdea6f0..ee3486fdb1 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -23,4 +23,5 @@ endif
LINUX_KERNEL_MD5SUM?=x
KERNEL:=2.$(word 2,$(subst ., ,$(strip $(LINUX_VERSION))))
+KERNEL_PATCHVER:=$(shell echo $(LINUX_VERSION) | cut -d. -f1,2,3 | cut -d- -f1)
diff --git a/include/kernel.mk b/include/kernel.mk
index 7f035c7bc5..817555cf0f 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -28,7 +28,6 @@ else
KERNEL_CROSS:=$(TARGET_CROSS)
endif
- KERNEL_PATCHVER:=$(shell echo $(LINUX_VERSION) | cut -d. -f1,2,3 | cut -d- -f1)
PLATFORM_DIR := $(TOPDIR)/target/linux/$(BOARD)-$(KERNEL)
PATCH_DIR ?= ./patches$(shell [ -d "./patches-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
KERNEL_BUILD_DIR ?= $(BUILD_DIR_BASE)/linux-$(KERNEL)-$(BOARD)$(if $(BUILD_SUFFIX),_$(BUILD_SUFFIX))