aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-06-27 12:58:08 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-06-27 12:58:08 +0000
commit5f417387b8a2efca374b29501852200cd2e2297e (patch)
tree58ea2d1d709b1fa9a9f56b859a05713714e2326a /include
parent5b32f12d226034077dc63b44060481329be2d354 (diff)
downloadupstream-5f417387b8a2efca374b29501852200cd2e2297e.tar.gz
upstream-5f417387b8a2efca374b29501852200cd2e2297e.tar.bz2
upstream-5f417387b8a2efca374b29501852200cd2e2297e.zip
make UbinizeImage work nicely without a kernel volume
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41359 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/image.mk9
1 files changed, 4 insertions, 5 deletions
diff --git a/include/image.mk b/include/image.mk
index 71971e21ca..5e4dfb28e9 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -142,15 +142,14 @@ ifneq ($(CONFIG_NAND_SUPPORT),)
"$(BIN_DIR)/$(IMG_PREFIX)-$(1)-$(2)-sysupgrade.tar" sysupgrade-$(1))
endef
# $(1) board name
-# $(2) ubinize-image options (e.g. --no-kernel and/or --uboot-env)
+# $(2) ubinize-image options (e.g. --uboot-env and/or --kernel kernelimage)
# $(3) rootfstype (e.g. squashfs or ubifs)
-# $(4) kernel image file
-# $(5) options to pass-through to ubinize (i.e. $($(PROFILE)_UBI_OPTS)))
+# $(4) options to pass-through to ubinize (i.e. $($(PROFILE)_UBI_OPTS)))
define Image/Build/UbinizeImage
sh $(TOPDIR)/scripts/ubinize-image.sh $(2) \
- "$(KDIR)/root.$(3)" "$(4)" \
+ "$(KDIR)/root.$(3)" \
"$(BIN_DIR)/$(IMG_PREFIX)-$(1)-$(3)-ubinized.bin" \
- $(5)
+ $(4)
endef
endif