aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2014-06-07 17:36:02 +0000
committerHauke Mehrtens <hauke@openwrt.org>2014-06-07 17:36:02 +0000
commit436d42c5cd36615355fd78e25f30d3a98afaa0c3 (patch)
tree630cc5e5905c058947b282e677ad1747d04cc5f3 /include
parent7e4ffc4002e374cc11155fe45f98b96b6acd3a41 (diff)
downloadupstream-436d42c5cd36615355fd78e25f30d3a98afaa0c3.tar.gz
upstream-436d42c5cd36615355fd78e25f30d3a98afaa0c3.tar.bz2
upstream-436d42c5cd36615355fd78e25f30d3a98afaa0c3.zip
brcm47xx: activate some compiler optimizations for 74K CPUs
With this patch the mips74k subtarget will be compiled with optimized compiler options to generated smaller and faster code. This currently breaks broadcom-wl, because the binary blob is only compiled with mipsr1 support. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41050 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/target.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index 72a6c34c4b..09ba911ff4 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -214,6 +214,7 @@ ifeq ($(DUMP),1)
CPU_CFLAGS_mips64 = -mips64 -mtune=mips64 -mabi=64
CPU_CFLAGS_24kec = -mips32r2 -mtune=24kec
CPU_CFLAGS_34kc = -mips32r2 -mtune=34kc
+ CPU_CFLAGS_74kc = -mips32r2 -mtune=74kc
CPU_CFLAGS_dsp = -mdsp
CPU_CFLAGS_dsp2 = -mdspr2
endif