aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-08-06 18:18:48 +0000
committerJohn Crispin <blogic@openwrt.org>2014-08-06 18:18:48 +0000
commit433125c1a631ef33db9d438d92c1af132c135b69 (patch)
tree03066ff4008f29bb5b33780c2b8c1cdf3e548682 /include
parent63cb54edd5e55ad7f89eea303deb34a2e38cf874 (diff)
downloadupstream-433125c1a631ef33db9d438d92c1af132c135b69.tar.gz
upstream-433125c1a631ef33db9d438d92c1af132c135b69.tar.bz2
upstream-433125c1a631ef33db9d438d92c1af132c135b69.zip
include: fix detection of installed feeds
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> Backport of r42003 git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@42017 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/feeds.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/feeds.mk b/include/feeds.mk
index 17ce64f83a..97b14491f0 100644
--- a/include/feeds.mk
+++ b/include/feeds.mk
@@ -8,8 +8,9 @@
-include $(TMP_DIR)/.packagefeeds
FEEDS_AVAILABLE:=$(shell $(SCRIPT_DIR)/feeds list -n)
-FEEDS_INSTALLED:=$(patsubst %.index,%,$(notdir $(wildcard $(TOPDIR)/feeds/*.index)))
+FEEDS_INSTALLED:=$(notdir $(wildcard $(TOPDIR)/package/feeds/*))
FEEDS_ENABLED:=$(foreach feed,$(FEEDS_INSTALLED),$(if $(CONFIG_FEED_$(feed)),$(feed)))
+FEEDS_DISABLED:=$(filter-out $(FEEDS_ENABLED),$(FEEDS_INSTALLED))
PKG_CONFIG_DEPENDS += \
CONFIG_PER_FEED_REPO \