aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-17 15:40:02 +0000
committerJohn Crispin <blogic@openwrt.org>2014-06-17 15:40:02 +0000
commit31f99ff64c0f013dfbdbc5267b96d21190b41219 (patch)
treed03fde9bd72d9be222ac77d60b95bf9e7c167e27 /include
parent7911faae005a1945f399da4f92130eea8921f34c (diff)
downloadupstream-31f99ff64c0f013dfbdbc5267b96d21190b41219.tar.gz
upstream-31f99ff64c0f013dfbdbc5267b96d21190b41219.tar.bz2
upstream-31f99ff64c0f013dfbdbc5267b96d21190b41219.zip
procd: some cleanup for SysupgradeNAND
Removed unused ubi file file from template as ubinized images are passed directly and not inside the tarball. Also removed left-over white-space. Signed-off-by: Daniel Golle <daniel@makrotopia.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41237 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/image.mk2
1 files changed, 0 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index 605474ce99..66ac497849 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -132,14 +132,12 @@ endif
# $(1): board name
# $(2): kernel image
# $(3): rootfs image
-# $(4): ubi image
ifneq ($(CONFIG_NAND_SUPPORT),)
define Image/Build/SysupgradeNAND
mkdir -p $(KDIR_TMP)/sysupgrade-$(1)/
echo "BOARD=$(1)" > $(KDIR_TMP)/sysupgrade-$(1)/CONTROL
[ -z "$(2)" ] || $(CP) $(2) $(KDIR_TMP)/sysupgrade-$(1)/kernel
[ -z "$(3)" ] || $(CP) $(3) $(KDIR_TMP)/sysupgrade-$(1)/root
- [ -z "$(4)" ] || $(CP) $(4) $(KDIR_TMP)/sysupgrade-$(1)/ubi
(cd $(KDIR_TMP); $(TAR) cvf \
$(BIN_DIR)/$(IMG_PREFIX)-$(1)-ubi-sysupgrade.tar sysupgrade-$(1))
endef