aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-10-18 06:58:11 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-10-18 06:58:11 +0000
commit089d03f61a8c4db1dfc28b407da39b69159e0b6c (patch)
treee957795558e95e2492150e76f5da2e9f832a605c /include
parent6591e5b4dd367d983d31de69ec17124793a838b7 (diff)
downloadupstream-089d03f61a8c4db1dfc28b407da39b69159e0b6c.tar.gz
upstream-089d03f61a8c4db1dfc28b407da39b69159e0b6c.tar.bz2
upstream-089d03f61a8c4db1dfc28b407da39b69159e0b6c.zip
[buildroot] make ModuleAutoLoad more readable
When doing a build with tracing on, the expansion of ModuleAutoLoad can get a little hairy. Using intermediate variables to name the arguments makes tracing more readable. One side effect is that if an argument is accidentally left out, we won't get all of the parameters shifted one over thanks to quoting (done in AutoLoad). Signed-of-by: Philip Prindeville <philipp@redfish-solutions.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23513 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/kernel.mk16
1 files changed, 10 insertions, 6 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 6ef4fd942d..6795bd49fc 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -67,16 +67,20 @@ define ModuleAutoLoad
$(SH_FUNC) \
export modules=; \
add_module() { \
+ priority="$$$$$$$$1"; \
+ mods="$$$$$$$$2"; \
+ boot="$$$$$$$$3"; \
+ shift 3; \
mkdir -p $(2)/etc/modules.d; \
( \
- [ "$$$$$$$$3" = "1" ] && { \
+ [ "$$$$$$$$boot" = "1" ] && { \
echo '# May be required for rootfs' ; \
} ; \
- for mod in $$$$$$$$2; do \
- getvar mod; \
+ for mod in $$$$$$$$mods; do \
+ echo "$$$$$$$$mod"; \
done \
- ) > $(2)/etc/modules.d/$$$$$$$$1-$(1); \
- modules="$$$$$$$${modules:+$$$$$$$$modules }$$$$$$$$1-$(1)"; \
+ ) > $(2)/etc/modules.d/$$$$$$$$priority-$(1); \
+ modules="$$$$$$$${modules:+$$$$$$$$modules }$$$$$$$$priority-$(1)"; \
}; \
$(3) \
if [ -n "$$$$$$$$modules" ]; then \
@@ -156,7 +160,7 @@ $(call KernelPackage/$(1)/config)
endef
define AutoLoad
- add_module $(1) "$(2)" $(3);
+ add_module "$(1)" "$(2)" "$(3)";
endef
ifdef DUMP