aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-07-24 23:07:30 +0000
committerJohn Crispin <blogic@openwrt.org>2012-07-24 23:07:30 +0000
commite4bf8e56a9d1c1295fa557574e44df360374c60e (patch)
tree8c9bdeb550112c19419ceb772fa548118b9e7be5 /include
parent28bcb29a44694cf4ace04652e73229cd04ca0659 (diff)
downloadupstream-e4bf8e56a9d1c1295fa557574e44df360374c60e.tar.gz
upstream-e4bf8e56a9d1c1295fa557574e44df360374c60e.tar.bz2
upstream-e4bf8e56a9d1c1295fa557574e44df360374c60e.zip
[include] package-version-override always calls autoreconf
make it conditional on the existance of autoreconf Signed-off-by: Ryan Nowakowski <tubaman@fattuba.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32831 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/package-version-override.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-version-override.mk b/include/package-version-override.mk
index eaaa3520f8..f69d9b1776 100644
--- a/include/package-version-override.mk
+++ b/include/package-version-override.mk
@@ -62,7 +62,7 @@ define prepare_custom_source_directory
rm -Rf $(PKG_BUILD_DIR); \
echo "Preparing Custom Source Directory link: $(CONFIG_$(PKG_NAME)_CUSTOM_SOURCE_DIR)"; \
ln -snf $(CONFIG_$(PKG_NAME)_CUSTOM_SOURCE_DIR) $(PKG_BUILD_DIR); \
- ( cd $(PKG_BUILD_DIR); autoreconf -i; ) \
+ [ -x "$(PKG_BUILD_DIR)/autoreconf" ] && (cd $(PKG_BUILD_DIR); autoreconf -i;) \
else \
echo "Custom Source Directory $(CONFIG_$(PKG_NAME)_CUSTOM_SOURCE_DIR) is invalid"; \
false; \