aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-04 19:36:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-04 19:36:11 +0000
commitd02d6519c49a26fc70995126c689b7ee758b191f (patch)
treed6eabd45b192ff4d93d1be5cbc5e3549cb3da85e /include
parent738e71e4ba2841b0af574970982af086dd1b2487 (diff)
downloadupstream-d02d6519c49a26fc70995126c689b7ee758b191f.tar.gz
upstream-d02d6519c49a26fc70995126c689b7ee758b191f.tar.bz2
upstream-d02d6519c49a26fc70995126c689b7ee758b191f.zip
Minor kernel build changes:
Change '[ -d ... ] && cmd' to 'if [ -d ... ]; then cmd; fi' to avoid make errors if the condition is false If $(PLATFORM_DIR)/files exists, copy it into the kernel tree on prepare. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6263 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/kernel-build.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index c0b17aa841..1ac847e93c 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -69,8 +69,9 @@ endif
define Kernel/Prepare/Default
bzcat $(DL_DIR)/$(LINUX_SOURCE) | tar -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
- [ -d $(GENERIC_PLATFORM_DIR)/patches ] && $(PATCH) $(LINUX_DIR) $(GENERIC_PLATFORM_DIR)/patches
- [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
+ if [ -d $(GENERIC_PLATFORM_DIR)/patches ]; then $(PATCH) $(LINUX_DIR) $(GENERIC_PLATFORM_DIR)/patches; fi
+ if [ -d ./files ]; then $(CP) ./files/* $(LINUX_DIR)/; fi
+ if [ -d ./patches ]; then $(PATCH) $(LINUX_DIR) ./patches; fi
endef
define Kernel/Prepare
$(call Kernel/Prepare/Default)