aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-05-17 14:19:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-05-17 14:19:36 +0000
commitc2d237515af8703257954484e8ee2fc1a318f244 (patch)
tree3bb79331d5ae4f7014b3a2f4430d74c64c681493 /include
parent2165d2b9508f61d0879c47f09f3fd261882fb8da (diff)
downloadupstream-c2d237515af8703257954484e8ee2fc1a318f244.tar.gz
upstream-c2d237515af8703257954484e8ee2fc1a318f244.tar.bz2
upstream-c2d237515af8703257954484e8ee2fc1a318f244.zip
cmake.mk: add support for overriding the source dir, and define the cmake prefix path to avoid picking up host libraries for target builds (patch by Henning Rogge)
Backport of r34914 git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@36652 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/cmake.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/include/cmake.mk b/include/cmake.mk
index 4c4af502cc..64a0654f96 100644
--- a/include/cmake.mk
+++ b/include/cmake.mk
@@ -4,6 +4,8 @@ ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)
MAKE_FLAGS+=VERBOSE=1
endif
+CMAKE_SOURCE_DIR:=.
+
ifeq ($(CONFIG_CCACHE),)
ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
CMAKE_C_COMPILER:=$(TOOLCHAIN_DIR)/bin/$(TARGET_CC)
@@ -53,8 +55,9 @@ define Build/Configure/Default
-DCMAKE_STRIP=: \
-DCMAKE_INSTALL_PREFIX=/usr \
-DDL_LIBRARY=$(STAGING_DIR) \
+ -DCMAKE_PREFIX_PATH=$(STAGING_DIR) \
$(CMAKE_OPTIONS) \
- . \
+ $(CMAKE_SOURCE_DIR) \
)
endef