aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-07-31 16:39:58 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-07-31 16:39:58 +0000
commit6e407c0bc961ef96644ba581dbd3e2d49c79057b (patch)
tree52039898a2098ed4bda256d5e5ca4c52b1166713 /include
parent19f4a7fb41e20c4bd9f61ca039471da25103e627 (diff)
downloadupstream-6e407c0bc961ef96644ba581dbd3e2d49c79057b.tar.gz
upstream-6e407c0bc961ef96644ba581dbd3e2d49c79057b.tar.bz2
upstream-6e407c0bc961ef96644ba581dbd3e2d49c79057b.zip
don't try to package ipt_SNAT and ipt_DNAT when making kernel module packages
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4354 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/netfilter.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index d4ec0f3915..ba1512e14a 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -77,7 +77,9 @@ IPT_IPSEC-$(CONFIG_IP_NF_MATCH_AH) += $(P_V4)ipt_ah
IPT_IPSEC-$(CONFIG_NETFILTER_XT_MATCH_ESP) += $(P_XT)xt_esp
IPT_NAT-m :=
-IPT_NAT-$(CONFIG_IP_NF_NAT) += $(P_V4)ipt_SNAT $(P_V4)ipt_DNAT
+ifneq ($(NF_KMOD),1)
+ IPT_NAT-$(CONFIG_IP_NF_NAT) += $(P_V4)ipt_SNAT $(P_V4)ipt_DNAT
+endif
IPT_NAT-$(CONFIG_IP_NF_TARGET_MASQUERADE) += $(P_V4)ipt_MASQUERADE
IPT_NAT-$(CONFIG_IP_NF_TARGET_MIRROR) += $(P_V4)ipt_MIRROR
IPT_NAT-$(CONFIG_IP_NF_TARGET_REDIRECT) += $(P_V4)ipt_REDIRECT