aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-06-11 12:56:03 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-06-11 12:56:03 +0000
commit3a873122a2de5e8af77041a080ca725ef7b3d2b6 (patch)
tree9872b017f71bcae8bd82137ec59847f5a4c734ec /include
parente9e85d3fd21fd6a4fb4e90222931530113fb131d (diff)
downloadupstream-3a873122a2de5e8af77041a080ca725ef7b3d2b6.tar.gz
upstream-3a873122a2de5e8af77041a080ca725ef7b3d2b6.tar.bz2
upstream-3a873122a2de5e8af77041a080ca725ef7b3d2b6.zip
build: clean up stale files from a previous build when installing a package build to the staging dir
Signed-off-by: Felix Fietkau <nbd@openwrt.org> Backport of r36755 git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@36916 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/package.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/package.mk b/include/package.mk
index 3ec5ffdadd..4af54cebc9 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -169,6 +169,11 @@ define Build/DefaultTargets
$(foreach hook,$(Hooks/InstallDev/Post),\
$(call $(hook),$(TMP_DIR)/stage-$(PKG_NAME),$(TMP_DIR)/stage-$(PKG_NAME)/host)$(sep)\
)
+ if [ -f $(STAGING_DIR)/packages/$(STAGING_FILES_LIST) ]; then \
+ $(SCRIPT_DIR)/clean-package.sh \
+ "$(STAGING_DIR)/packages/$(STAGING_FILES_LIST)" \
+ "$(STAGING_DIR)"; \
+ fi
if [ -d $(TMP_DIR)/stage-$(PKG_NAME) ]; then \
(cd $(TMP_DIR)/stage-$(PKG_NAME); find ./ > $(TMP_DIR)/stage-$(PKG_NAME).files); \
$(call locked, \