aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-28 21:03:06 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-28 21:03:06 +0000
commit0440e2af341162ffdb0ee37d2baac0c9d166824e (patch)
treefcc87cffb8692d17024cbc0d03841b07a345d6fb /include
parentf0d6629f64e17c671f5496906f592d0ca930b662 (diff)
downloadupstream-0440e2af341162ffdb0ee37d2baac0c9d166824e.tar.gz
upstream-0440e2af341162ffdb0ee37d2baac0c9d166824e.tar.bz2
upstream-0440e2af341162ffdb0ee37d2baac0c9d166824e.zip
add staging_dir/host/lib to LD_LIBRARY_PATH so that host-built applications can install and make use of shared libraries
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14698 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/toplevel.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 6d46fe1edd..eaaf6d37d1 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -23,6 +23,8 @@ export RELEASE
export REVISION
export OPENWRTVERSION
export IS_TTY=$(shell tty -s && echo 1 || echo 0)
+export LD_LIBRARY_PATH:=$(if $(LD_LIBRARY_PATH),$(LD_LIBRARY_PATH):)$(STAGING_DIR_HOST)/lib
+export DYLD_LIBRARY_PATH:=$(if $(DYLD_LIBRARY_PATH),$(DYLD_LIBRARY_PATH):)$(STAGING_DIR_HOST)/lib
# make sure that a predefined CFLAGS variable does not disturb packages
export CFLAGS=