aboutsummaryrefslogtreecommitdiffstats
path: root/include/version.mk
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2018-01-24 17:33:21 -0700
committerJo-Philipp Wich <jo@mein.io>2018-02-02 13:59:34 +0100
commitff8e9a4ecbe70564c8649ea4ed69f28bec77dfa7 (patch)
treed501f58707acf6d423fd79f231c6f0dffb38003c /include/version.mk
parentabbb07a6616afa942d69d8b612cfad90213d40eb (diff)
downloadupstream-ff8e9a4ecbe70564c8649ea4ed69f28bec77dfa7.tar.gz
upstream-ff8e9a4ecbe70564c8649ea4ed69f28bec77dfa7.tar.bz2
upstream-ff8e9a4ecbe70564c8649ea4ed69f28bec77dfa7.zip
treewide: combine VERSION_SED and VERSION_SED_SCRIPT
We don't need two versions of this. The escaping quotes is so that the sed commands aren't misinterpreted by shell; it has nothing to do with the contents of the file, thus one version is adequate. Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'include/version.mk')
-rw-r--r--include/version.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/include/version.mk b/include/version.mk
index 6c6eb75ff6..ab427ecba8 100644
--- a/include/version.mk
+++ b/include/version.mk
@@ -85,7 +85,7 @@ $(subst &,\&,$(subst $(comma),\$(comma),$(subst ','\'',$(subst \,\\,$(1)))))
endef
#'
-VERSION_SED:=$(SED) 's,%U,$(call sed_escape,$(VERSION_REPO)),g' \
+VERSION_SED_SCRIPT:=$(SED) 's,%U,$(call sed_escape,$(VERSION_REPO)),g' \
-e 's,%V,$(call sed_escape,$(VERSION_NUMBER)),g' \
-e 's,%v,\L$(call sed_escape,$(subst $(space),_,$(VERSION_NUMBER))),g' \
-e 's,%C,$(call sed_escape,$(VERSION_CODE)),g' \
@@ -104,4 +104,3 @@ VERSION_SED:=$(SED) 's,%U,$(call sed_escape,$(VERSION_REPO)),g' \
-e 's,%P,$(call sed_escape,$(VERSION_PRODUCT)),g' \
-e 's,%h,$(call sed_escape,$(VERSION_HWREV)),g'
-VERSION_SED_SCRIPT:=$(VERSION_SED)