aboutsummaryrefslogtreecommitdiffstats
path: root/include/u-boot.mk
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2021-10-19 11:08:46 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2021-10-24 18:00:49 +0200
commit09465d802b8ce37ee87b6d104889059a6fa948e6 (patch)
treeba09f0095e95575ec4999eed7dcc9f90072f679b /include/u-boot.mk
parent0e411c69a819bf3c8a122d8421d6c1c0ded33ec8 (diff)
downloadupstream-09465d802b8ce37ee87b6d104889059a6fa948e6.tar.gz
upstream-09465d802b8ce37ee87b6d104889059a6fa948e6.tar.bz2
upstream-09465d802b8ce37ee87b6d104889059a6fa948e6.zip
u-boot.mk: always link host libraries static
Host libraries are only build static, so let's pass --static to pkg-config globally and remove the then unnecessary patches doing exactly that individually. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'include/u-boot.mk')
-rw-r--r--include/u-boot.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/u-boot.mk b/include/u-boot.mk
index 8c6941b88a..509b3d76dc 100644
--- a/include/u-boot.mk
+++ b/include/u-boot.mk
@@ -48,6 +48,7 @@ UBOOT_MAKE_FLAGS = \
STAGING_PREFIX="$(STAGING_DIR_HOST)" \
PKG_CONFIG_PATH="$(STAGING_DIR_HOST)/lib/pkgconfig" \
PKG_CONFIG_LIBDIR="$(STAGING_DIR_HOST)/lib/pkgconfig" \
+ PKG_CONFIG_EXTRAARGS="--static" \
$(if $(findstring c,$(OPENWRT_VERBOSE)),V=1,V='')
define Build/U-Boot/Target