aboutsummaryrefslogtreecommitdiffstats
path: root/include/u-boot.mk
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2018-01-22 17:30:06 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2018-02-10 20:52:31 +0100
commitdf9781a4205c5191fe21e795f732cfdd37d982f9 (patch)
treebd472b4ba66f605c9efe135753cbc328055dbe34 /include/u-boot.mk
parentd0d37e89afd1172874e0c587278bdfe38d16cbe4 (diff)
downloadupstream-df9781a4205c5191fe21e795f732cfdd37d982f9.tar.gz
upstream-df9781a4205c5191fe21e795f732cfdd37d982f9.tar.bz2
upstream-df9781a4205c5191fe21e795f732cfdd37d982f9.zip
u-boot,at91bootstrap: fix incorrect HOSTCPPFLAGS variable
This would should up as `$$(HOSTCPPFLAGS)` in the host CFLAGS. ``` make --jobserver-fds=3,4 -j -C <openwrt>/build_dir/target-arm_cortex-a8+vfpv3_musl_eabi/u-boot-A10-OLinuXino-Lime/u-boot-2017.07 CROSS_COMPILE=arm-openwrt-linux-muslgnueabi- DTC="<openwrt>/build_dir/target-arm_cortex-a8+vfpv3_musl_eabi/linux-sunxi_cortexa8/linux-4.9.76/scripts/dtc/dtc" HOSTCC="gcc" HOSTCFLAGS='-O2 -I<openwrt>/staging_dir/host/include -I<openwrt>/staging_dir/host/usr/include -I<openwrt>/staging_dir/hostpkg/include -I<openwrt>/staging_dir/target-arm_cortex-a8+vfpv3_musl_eabi/host/include $$(HOSTCPPFLAGS)' HOSTLDFLAGS="" BL31=<openwrt>/staging_dir/target-arm_cortex-a8+vfpv3_musl_eabi/image/bl31.bin ``` And then it would complain with: ``` /bin/sh: 1: HOSTCPPFLAGS: not found ``` Also, HOSTCPPFLAGS does not exist. The correct var is HOST_CPPFLAGS. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'include/u-boot.mk')
-rw-r--r--include/u-boot.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/u-boot.mk b/include/u-boot.mk
index 4b3ff69d6b..5bcf0315d3 100644
--- a/include/u-boot.mk
+++ b/include/u-boot.mk
@@ -42,7 +42,7 @@ TARGET_DEP = TARGET_$(BUILD_TARGET)$(if $(BUILD_SUBTARGET),_$(BUILD_SUBTARGET))
UBOOT_MAKE_FLAGS = \
HOSTCC="$(HOSTCC)" \
- HOSTCFLAGS='$(HOST_CFLAGS) $$$$(HOSTCPPFLAGS)' \
+ HOSTCFLAGS="$(HOST_CFLAGS) $(HOST_CPPFLAGS)" \
HOSTLDFLAGS=""
define Build/U-Boot/Target