aboutsummaryrefslogtreecommitdiffstats
path: root/include/u-boot.mk
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2018-01-23 16:51:52 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2018-02-10 20:52:31 +0100
commitc72e6582c073b489348df3fedb273456d504559f (patch)
tree08bef4b58e928c61e5fb273c32288550e2cbf0fe /include/u-boot.mk
parentdf9781a4205c5191fe21e795f732cfdd37d982f9 (diff)
downloadupstream-c72e6582c073b489348df3fedb273456d504559f.tar.gz
upstream-c72e6582c073b489348df3fedb273456d504559f.tar.bz2
upstream-c72e6582c073b489348df3fedb273456d504559f.zip
u-boot.mk: add HOST_LDFLAGS to UBOOT_MAKE_FLAGS
This will make sure that the build system's paths for linking are available. This is needed mostly for linking with tools/libressl. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'include/u-boot.mk')
-rw-r--r--include/u-boot.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/u-boot.mk b/include/u-boot.mk
index 5bcf0315d3..babb76497a 100644
--- a/include/u-boot.mk
+++ b/include/u-boot.mk
@@ -43,7 +43,7 @@ TARGET_DEP = TARGET_$(BUILD_TARGET)$(if $(BUILD_SUBTARGET),_$(BUILD_SUBTARGET))
UBOOT_MAKE_FLAGS = \
HOSTCC="$(HOSTCC)" \
HOSTCFLAGS="$(HOST_CFLAGS) $(HOST_CPPFLAGS)" \
- HOSTLDFLAGS=""
+ HOSTLDFLAGS="$(HOST_LDFLAGS)"
define Build/U-Boot/Target
$(eval $(call U-Boot/Init,$(1)))