aboutsummaryrefslogtreecommitdiffstats
path: root/include/u-boot.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-03-16 09:01:56 +0100
committerFelix Fietkau <nbd@nbd.name>2017-04-04 12:34:23 +0200
commit68139cc0e819b5f654c4f78468049eef035d28f7 (patch)
tree5fb2a73e6069236821c0182c4d98b6ed590839e5 /include/u-boot.mk
parentd3bc11857af788e185e8a3ece26ce40757cf3965 (diff)
downloadupstream-68139cc0e819b5f654c4f78468049eef035d28f7.tar.gz
upstream-68139cc0e819b5f654c4f78468049eef035d28f7.tar.bz2
upstream-68139cc0e819b5f654c4f78468049eef035d28f7.zip
u-boot.mk: pass HOSTCC and HOST_CFLAGS into the build
Cuts build time on Mac OS X in half by avoiding repeated $(shell) calls from the build system Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/u-boot.mk')
-rw-r--r--include/u-boot.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/u-boot.mk b/include/u-boot.mk
index 0c28653326..4b3ff69d6b 100644
--- a/include/u-boot.mk
+++ b/include/u-boot.mk
@@ -40,6 +40,11 @@ endef
TARGET_DEP = TARGET_$(BUILD_TARGET)$(if $(BUILD_SUBTARGET),_$(BUILD_SUBTARGET))
+UBOOT_MAKE_FLAGS = \
+ HOSTCC="$(HOSTCC)" \
+ HOSTCFLAGS='$(HOST_CFLAGS) $$$$(HOSTCPPFLAGS)' \
+ HOSTLDFLAGS=""
+
define Build/U-Boot/Target
$(eval $(call U-Boot/Init,$(1)))
$(eval $(call U-Boot/Default,$(1)))