aboutsummaryrefslogtreecommitdiffstats
path: root/include/trusted-firmware-a.mk
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2022-12-02 12:54:52 +0000
committerDaniel Golle <daniel@makrotopia.org>2022-12-05 01:28:28 +0000
commit0579d9f5bc4b3a3d1b32526c71a6b77c4888bfcb (patch)
treedfff7256658473bb48f88d8c99154ce80b116b72 /include/trusted-firmware-a.mk
parenta224412bbc3ab62cbaacb5a3e5e0a8f16ce5da5f (diff)
downloadupstream-0579d9f5bc4b3a3d1b32526c71a6b77c4888bfcb.tar.gz
upstream-0579d9f5bc4b3a3d1b32526c71a6b77c4888bfcb.tar.bz2
upstream-0579d9f5bc4b3a3d1b32526c71a6b77c4888bfcb.zip
trusted-firmware-a.mk: fix build with binutils 2.39
Starting from version 2.39 binutils now warns about sections with rwx permissions. While this is generally desirable it breaks building ARM TrustedFirmware-A bl2 which treats warnings as errors. Disable the warning/error for now to fix build. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'include/trusted-firmware-a.mk')
-rw-r--r--include/trusted-firmware-a.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/trusted-firmware-a.mk b/include/trusted-firmware-a.mk
index 46fc52b15e..0b37c0f943 100644
--- a/include/trusted-firmware-a.mk
+++ b/include/trusted-firmware-a.mk
@@ -81,6 +81,7 @@ define Build/Compile/Trusted-Firmware-A
$(if $(DTC),DTC="$(DTC)") \
PLAT=$(PLAT) \
BUILD_STRING="OpenWrt v$(PKG_VERSION)-$(PKG_RELEASE) ($(VARIANT))" \
+ $(if $(CONFIG_BINUTILS_VERSION_2_39),LDFLAGS="-no-warn-rwx-segments") \
$(TFA_MAKE_FLAGS)
endef