aboutsummaryrefslogtreecommitdiffstats
path: root/include/trusted-firmware-a.mk
diff options
context:
space:
mode:
authorLinhui Liu <liulinhui36@gmail.com>2023-01-17 09:27:38 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2023-01-21 11:55:23 +0100
commitc783c50d65966e7c3caa156e4df67e2fcc3aa168 (patch)
tree11bdf7c15862f4549b15e2d1e656f574cf718a30 /include/trusted-firmware-a.mk
parent8dc6c1edc447820a24a358ae3706ada58c031b91 (diff)
downloadupstream-c783c50d65966e7c3caa156e4df67e2fcc3aa168.tar.gz
upstream-c783c50d65966e7c3caa156e4df67e2fcc3aa168.tar.bz2
upstream-c783c50d65966e7c3caa156e4df67e2fcc3aa168.zip
trusted-firmware-a.mk: fix build with binutils 2.39+
Starting from version 2.39 binutils now warns about sections with rwx permissions. While this is generally desirable it breaks building ARM TrustedFirmware-A bl2 which treats warnings as errors. Disable the warning/error for now to fix build. Reference: 0579d9f5bc4b3a3d1b32526c71a6b77c4888bfcb Signed-off-by: Linhui Liu <liulinhui36@gmail.com>
Diffstat (limited to 'include/trusted-firmware-a.mk')
-rw-r--r--include/trusted-firmware-a.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/trusted-firmware-a.mk b/include/trusted-firmware-a.mk
index 082ada269c..0c0118e092 100644
--- a/include/trusted-firmware-a.mk
+++ b/include/trusted-firmware-a.mk
@@ -81,7 +81,7 @@ define Build/Compile/Trusted-Firmware-A
$(if $(DTC),DTC="$(DTC)") \
PLAT=$(PLAT) \
BUILD_STRING="OpenWrt v$(PKG_VERSION)-$(PKG_RELEASE) ($(VARIANT))" \
- $(if $(CONFIG_BINUTILS_VERSION_2_39),LDFLAGS="-no-warn-rwx-segments") \
+ $(if $(CONFIG_BINUTILS_VERSION_2_37)$(CONFIG_BINUTILS_VERSION_2_38),,LDFLAGS="-no-warn-rwx-segments") \
$(TFA_MAKE_FLAGS)
endef