aboutsummaryrefslogtreecommitdiffstats
path: root/include/trusted-firmware-a.mk
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2022-04-09 22:00:50 +0100
committerDaniel Golle <daniel@makrotopia.org>2022-04-09 22:24:36 +0100
commit738d44f5ea6f6450c2c8a29cf5836e22b479340b (patch)
tree6de2ee65f2cf097714b4e25ff7cdad3a24dc3ebe /include/trusted-firmware-a.mk
parentb92ec82235b996ece32bc84af177adf1a4dcb90e (diff)
downloadupstream-738d44f5ea6f6450c2c8a29cf5836e22b479340b.tar.gz
upstream-738d44f5ea6f6450c2c8a29cf5836e22b479340b.tar.bz2
upstream-738d44f5ea6f6450c2c8a29cf5836e22b479340b.zip
trusted-firmware-a.mk: make sure include directory exists
ARM Trusted Firmware builds do not depend on any target libraries as they are bare-metal builds. However, the compiler aborts due to -Werror=missing-include-dirs if the include dir doesn't exists and this can happen when building with parallelisation as that makes it likely for arm-trusted-firmware-* to be build very early before any of the libraries which would implicitely create the directory. Fix this by making sure the include dir exists before building. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'include/trusted-firmware-a.mk')
-rw-r--r--include/trusted-firmware-a.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/trusted-firmware-a.mk b/include/trusted-firmware-a.mk
index dd740c45f2..d95250452b 100644
--- a/include/trusted-firmware-a.mk
+++ b/include/trusted-firmware-a.mk
@@ -68,6 +68,9 @@ define Build/Trusted-Firmware-A/Target
endef
endef
+define Build/Configure/Trusted-Firmware-A
+ $(INSTALL_DIR) $(STAGING_DIR)/usr/include
+endef
define Build/Compile/Trusted-Firmware-A
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \