aboutsummaryrefslogtreecommitdiffstats
path: root/include/trusted-firmware-a.mk
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2022-04-09 22:00:50 +0100
committerDaniel Golle <daniel@makrotopia.org>2022-04-10 16:32:20 +0100
commit725a7619de20600a7c93dde9258791704d95636a (patch)
treea92b40690a4c3b09b7550335ebfa013ac6ae4e83 /include/trusted-firmware-a.mk
parent662d1f9f8db3e8bd295dc93b9fd5383741bbadf5 (diff)
downloadupstream-725a7619de20600a7c93dde9258791704d95636a.tar.gz
upstream-725a7619de20600a7c93dde9258791704d95636a.tar.bz2
upstream-725a7619de20600a7c93dde9258791704d95636a.zip
trusted-firmware-a.mk: make sure include directory exists
ARM Trusted Firmware builds do not depend on any target libraries as they are bare-metal builds. However, the compiler aborts due to -Werror=missing-include-dirs if the include dir doesn't exists and this can happen when building with parallelisation as that makes it likely for arm-trusted-firmware-* to be build very early before any of the libraries which would implicitely create the directory. Fix this by making sure the include dir exists before building. Signed-off-by: Daniel Golle <daniel@makrotopia.org> (cherry picked from commit 738d44f5ea6f6450c2c8a29cf5836e22b479340b)
Diffstat (limited to 'include/trusted-firmware-a.mk')
-rw-r--r--include/trusted-firmware-a.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/trusted-firmware-a.mk b/include/trusted-firmware-a.mk
index dd740c45f2..d95250452b 100644
--- a/include/trusted-firmware-a.mk
+++ b/include/trusted-firmware-a.mk
@@ -68,6 +68,9 @@ define Build/Trusted-Firmware-A/Target
endef
endef
+define Build/Configure/Trusted-Firmware-A
+ $(INSTALL_DIR) $(STAGING_DIR)/usr/include
+endef
define Build/Compile/Trusted-Firmware-A
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \