aboutsummaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2022-02-21 11:50:39 +0100
committerPetr Štetiar <ynezz@true.cz>2022-02-22 16:37:23 +0100
commit418dc0497db02b1ccddf26009e16d42496b7f554 (patch)
treee6902f1736190ea2050fb0e3602e8fdb83c89d67 /include/toplevel.mk
parent0134f845dab95e0e7f885f4e227d9a41aedf909d (diff)
downloadupstream-418dc0497db02b1ccddf26009e16d42496b7f554.tar.gz
upstream-418dc0497db02b1ccddf26009e16d42496b7f554.tar.bz2
upstream-418dc0497db02b1ccddf26009e16d42496b7f554.zip
build: toplevel.mk: fix missing kconfig dependency tracking
Toplevel Make is not aware about changes in the `scripts/config/*conf` targets and this is causing issues for during update to that part of build tree, where one needs to handle this manually by either force rebuilding the targets or running `make config-clean`. Fix this by forcing the rebuild if necessary. Fixes: #9297 Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 1e543ebcb9..ce744bc92c 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -101,7 +101,7 @@ ifneq ($(DISTRO_PKG_CONFIG),)
scripts/config/%onf: export PATH:=$(dir $(DISTRO_PKG_CONFIG)):$(PATH)
endif
scripts/config/%onf: CFLAGS+= -O2
-scripts/config/%onf:
+scripts/config/%onf: FORCE
@$(_SINGLE)$(SUBMAKE) $(if $(findstring s,$(OPENWRT_VERBOSE)),,-s) \
-C scripts/config $(notdir $@)