aboutsummaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-12-14 00:33:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-12-14 00:33:25 +0000
commit2da3f6a25641ed7442141ce07943afaaad3b8c31 (patch)
treecaee1a081d413e9ae89ceea521123b8cfa7e0d0e /include/toplevel.mk
parent809bc0321fd97187df0ea2838caf857c56d3952a (diff)
downloadupstream-2da3f6a25641ed7442141ce07943afaaad3b8c31.tar.gz
upstream-2da3f6a25641ed7442141ce07943afaaad3b8c31.tar.bz2
upstream-2da3f6a25641ed7442141ce07943afaaad3b8c31.zip
fix the sdk
SVN-Revision: 9747
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 63325aa018..4e194bf50a 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -12,7 +12,12 @@ PREP_MK= OPENWRT_BUILD= QUIET=0
include $(TOPDIR)/include/verbose.mk
-REVISION:=$(shell $(TOPDIR)/scripts/getver.sh)
+ifeq ($(SDK),1)
+ include $(TOPDIR)/include/version.mk
+else
+ REVISION:=$(shell $(TOPDIR)/scripts/getver.sh)
+endif
+
OPENWRTVERSION:=$(RELEASE)$(if $(REVISION), ($(REVISION)))
export RELEASE
export REVISION